miércoles, 14 de noviembre de 2007

Problemas con AVG Free, info y pedido de ayuda

Los hechos:
  1. Ayer, martes 13 de Noviembre de 2007, MONTONES de máquinas dejaron de funcionar, pasando a un loop infinito de arranque-reinicio. En mi lugar de trabajo (y por lo que sé en muchos otros) fueron aproximadamente un 25% de las que tenían conexión a internet, incluidas las que tenían cerrado en el firewall todo menos el mail y la pagina de actualizacion del AVG. Lo mismo entre mis clientes particulares.
  2. Según pude comprobar, todas las maquinas afectadas tenían windows XP SP2 (pirata) y AVG Free.
  3. Muchos de los afectados dicen que vieron aparecer anuncios de virus mientras usaban la máquina, y las aplicaciones dejaron de funcionar, con un error del user32.dll. Al reiniciar la máquina, el bucle.
  4. El AVG borró al menos un archivo de sistema (user32.dll), por considerarlo infectado.
  5. Las máquinas que no se actualizaron el 13 no sufrieron inconvenientes (tengo del 12 y del 14).
Hasta aquí los hechos, ahora las hipótesis.
  1. Puede haber sido un virus que se haya propagado por mail de forma silenciosa desde hace un tiempo, que el antivirus no detectó, y que se activó ayer (que era martes 13, el viernes 13 de los sudacas). Si es así, no veo porqué no se activó al arranque, sino después de un rato en varias máquinas.
  2. Puede ser que el mismo virus estuviera activado, pero el AVG lo detectó recién con la actualización de ayer (más probable para mi).
  3. Puede ser una actualización defectuosa, que detectó como virus archivos de sistema válidos (hipótesis a la que suscribo, por pura paranoia).
  4. Puede ser caualidad (hipótesis ingenua).
  5. Aclaración: hipótesis conspiranoica y delirante. Puede ser una actualización maliciosa, destinada a desactivar a la fuerza windows XP pirata, con base en un acuerdo comercial entre AVG y Microsoft. Como refuerzo de la locura, vengo notando que AVG ultimamente incorporo reglas de detección que se comieron varios crack de programas que venían usando mis clientes hace meses. Sospechoso. Debo consultar a mi psiquiatra para que me cambie la medicación?
Soluciones
  1. Hasta el momento ninguna. El método más rápido que encontré para volver a la vida las maquinas circulares es reparar la instalación del windows ,lo que es equivalente a la instalación, pero deja en su lugar el registro, y con el los drivers y programas instalados. Tarda mas o menos una hora.
  2. Desinstalar AVG. Es culpable por acción o por omisión. Estoy probando AntiVir
Conclusiones
  1. Help!
Sería bueno que comenten si tuvieron problemas similares, o si tienen algun dato, hipótesis o solución que agregar. Si es así, entre todos quizás lleguemos a una respuesta. Gracias!

15 comentarios:

Anónimo dijo...

Nosotros en el Pc de clase tenemos un Xp SP2 "Pirateed Edition" junto con el AVG Free y no ha pasado nada, todo sigue funcionando como si tal cosa...

Supongo que no tendre que ver, pero lo tenemos instalado en una máquina virtual de VirtualBox corriendo sobre un Ubuntu 7.04 actualizado...

Por si acaso tenemos hecho un BackUp del disco duro de la máquina virtual no vayamos a tocar algo durante las prácticas que no debamos ^^' jejeje

Un saludo, y espero que encuentres solución al tema!! ;)

jack dijo...

jajajaja curioso. Ahora mismo voy a publicar una entrada contando lo que me paso en una maquina con lo que relatas.
Gracias por contarlo :).

A mi tambien me ha pasado.
xDDDDDDDD

jack dijo...

Usas xp profesional corporativo ?
Responde y salimos de dudas. Estoy contigo con lo de que es un acuerdo con microsoft.

Saludos y espero una contestacion para salir de dudas.
Gran articulo y gran blog por cierto.

Anónimo dijo...

perdon Jack no entendi la ironia del comentario. yo uso Nod32 y no tengo problemas

Anónimo dijo...

Usa Nod32 sin dudarlo.

jack dijo...

No lleva ironia. simplemente que algo ha pasado raro con el AVG free.
Justo el Martes 13 han saltado una serie de virus y al reiniciar las maquinas "infectadas" ya no arrancan, entran en loop infinito por la ausencia del fichero user*.*

Y no solo le ocurre a 486, en mi empresa tambien ha pasado y es probable que vengan ordenadores a reparar con el mismo problema.
La solucion no va a ser usar nod32, espero poder ponerles una debian y tirando para largo.

[486] dijo...

Jack: las 6 maquinas que llevo vistas con este problema tenian XP professional (no enterprise). Y parece que puede hacerse una "cura" mas rapida, copiando un user32.dll sano, arrancando en modo a prueba de fallos y desinstalando completamente el AVG. El que lo pruebe primero que avise, que si funciona da para una actualizacion del post.

Gon dijo...

yo use mi pc todo el dia (XP2, avg free, conexion a internet, firewall) y no paso nada.. sera que alguien les mando un bichito a proposito?? porque si hubiera sido de afuera se hubiera activado un viernes 13 (que es el dia que ellos consideran como martes 13), y no ayer...

David dijo...

Uff vaya problemon. Estos sucesos disparan todas las alarmas. En pocos sitios tengo el avg, pero de momento ningún cliente se me ha quejado. De todas formas donde lo tengo instalado son xp home originales.Así que el escenario no es el mismo.
Yo me pondría en contacto con la gente avg y les expondría el caso el cual me parece sumamente grabe.
Saludos y suerte.

Wardog dijo...

Otro escenario que me ha ocurrido a mi, por fortuna con pocas consecuencias es un virus que infectaba .exes.
AVG los borraba con todo el cariño del mundo. Por fortuna, el virus no profundizaba mucho en el arbol de directorios, que si no la hubiese liado gordota gordota...
Yo también votaría por el tema de la conspiración. Ya pasó con Sony y Symantec, que identificaba como virus el fichero para el downgrade de la PSP... Ascazo, por $Deity.

Anónimo dijo...

hola a todos!! tengo muuuuuuuchos clientes con la version de "windows xp prof pirated" y avg free todos conectados a internet y solo a uno le paso eso (y encima lo tenia original y el avg instalado desd hace un par de semanas) pero resulta curioso la verdad, estare atento... ahhh y solucione con reparacion de windows. salu2.

Edu dijo...

Aquí tengo otro ordenador más con el mismo problema, mismo software instalado. No sospeché nada porque ese mismo ordenador llevaba dando fallos desde hace unas semanas (errores en el disco duro probablemente)

[486] dijo...

Gracias a todos por sus aportes.
En el siguiente post hay un intento de cierre al tema. Si tienen algo que agregar, encantado.

Anónimo dijo...

Recien hoy recibo una PC con este problema, al ejecutar los programas del escritorio iban a la pantalla "abrir con" y si querias ver en el panel de control SISTEMAS
daba error "falta c:\windows\system\rundll32.exe "
La reintalacion encima no reparó nada
La hago corta: reemplace el rundll32.exe y el user32.dll copiandolos via DOS desde el CD

Anónimo dijo...

el idiota que escribio eso no tiene la mas minima idea de lo que pasa, yo tengo el XP original y tampoco me funciona